525.832 aktive Mitglieder*
3.314 Besucher online*
Kostenfrei registrieren
Anmelden Registrieren
FANUC Forum
Beitrag 22.06.2020, 13:50 Uhr
jejo
jejo
Level 2 = IndustryArena-Facharbeiter
**
Gruppe: Mitglied
Mitglied seit: 14.08.2014
Beiträge: 50

Hallo zusammen,
ich arbeite an einer Spinner TC52 Maschine mit Fanuc 21i Steuerung und Manual Guide.
Zum Werkzeugwechselpunktanfahren nutze ich G53 X? Z?, um im Maschinenkoordinatensystem immer auf eine sichere Koordinate zu fahren.
Die Parameter meiner Maschine sind so eingestellt, dass sowohl die X- als auch die Z-Achse im Eilgang auf die angesteuerte Position fahren. Dabei Interpoliert die Maschine den Weg allerdings nicht, sondern jede Achse fährt unabhängig von der anderen.

Gibt es eine Möglichkeit, dass beide Achsen zum gleichen Zeitpunkt an ihrer programmierten Endposition ankommen?

Und was mir gerade noch einfällt... Sobald ich G53 programmiere, fährt die Maschine im Eilgang. Bei G98; G1 G53 F3000;, fährt sie ebenfalls im Eilgang. Woran liegt dies?

Vielen Dank
Gruß,
Jens

Der Beitrag wurde von jejo bearbeitet: 22.06.2020, 13:54 Uhr
TOP    
Beitrag 22.06.2020, 16:16 Uhr
gram
gram
Level 3 = IndustryArena-Techniker
***
Gruppe: Mitglied
Mitglied seit: 20.04.2006
Beiträge: 172

Wenn du beide Achsen in einer geraden Linie interpoliert verfahren möchtest, dann setz in Parameter 1401 das Bit 1 (LRP) auf1.
Und meines Wissens ist G53 automatisch im Eilgang. Aber ich lasse mich gern eines Besseren belehren.

Gruß André
TOP    
Beitrag 22.06.2020, 16:40 Uhr
jejo
jejo
Level 2 = IndustryArena-Facharbeiter
**
Gruppe: Mitglied
Mitglied seit: 14.08.2014
Beiträge: 50

ZITAT(gram @ 22.06.2020, 17:16 Uhr) *
Wenn du beide Achsen in einer geraden Linie interpoliert verfahren möchtest, dann setz in Parameter 1401 das Bit 1 (LRP) auf1.
Und meines Wissens ist G53 automatisch im Eilgang. Aber ich lasse mich gern eines Besseren belehren.

Gruß André


Hallo Andre,
habe heute wegen eines anderen Problems mit dem Spinner Support telefoniert und dabei auch die oben genannten Fragen gestellt. Auf Parameter 1401 hat Support mich ebenfalls hingewiesen. Bit 1 ist bei mir bereits auf 1 gesetzt. Hierdurch wird eine "Schein"-Interpolation durchgeführt. Es entsteht keine perfekte gerade Linie, sondern eher ein Bogen. Eine andere Möglichkeit gäbe es nicht.
Wenn es nicht anders geht, auch nicht schlimm. Hauptsache ich weiß es smile.gif

Der Herr am Telefon teilte mir auch mit, dass G53 automatisch nur im Eilgang verfährt. Bei neueren Steuerungen gäbe es allerdings eine Option, die G53.1 o.ä. freischaltet, wodurch man dann auch im Vorschub fahren kann.

Mein Post hat sich somit erledigt smile.gif

Danke für deine Antwort! smile.gif
TOP    



1 Besucher lesen dieses Thema (Gäste: 1)
0 Mitglieder: