Kostenfrei registrieren
Anmelden Registrieren
484.696 reg. Mitglieder
484.696 reg. Mitglieder

Problem mit Datenübertragung Gildemeister

Beitrag 12.01.2018, 12:58 Uhr
janosch88
janosch88
Level 1 = IndustryArena-Lehrling
*
Gruppe: Mitglied.DE
Mitglied seit: 12.01.2018
Beiträge: 1

Hallo,

ich versuche grade den alten 486er durch einen moderneren PC zu ersetzen und habe mir ein paar DNC Programme runtergeladen.
Alle funktionieren von der eigentlichen Kommunikation her sofort aber das was ankommt ist nicht so schön, denn das sieht so aus:

f~~fx~~~~~f`x~~~`~~`~f`x~~fx`~~f~x~xf`x~~fxx~`x~~x~x~f`x~~fxfx~xx~~fxx~`~f`x~~~x~`~~`~fxxxx~~~x~`x~`~xx~fx`~x`~~f`x~~~~`x~~~~~`~x~~fx~`x~~~xxfx~f`x~~fx~`~~xx~`x~x~~fx~~`~~~~f`x~~fxxx~`x~`~x~~~fx~`x~~~x~f`x~~~~`~~xx~`x~x~~~xx~`~~~~xxxx~~`~x~`~~ff`~xfxx~~`~`~~`x~~~fx~x~x~~~x~`x~x~x~~xx~`~~~fx~~`x~fxx~~~~~`x~`~x~~`~~`x~~~fxf`x~~`~~`~~xx~x~~`~~~`~~~x`~x~~`~xx~`~~x`~`~~x~~xx~`~~~~xx~~x~~`x~`~x~~x~~`x~~xx~f`x~~xx~`~~xx~x~~x`~~`x~~~x~xxx~~xfx~`x~`~x~~`~x~`~f`x~~`~~`x~xxxx~fxx~xf`x~~`~fx~`x~~x~x~f`x~~xxx~`~~xxxx~`xxfxx~~x~~~`x~x~xxx~~x~~`~`~x~~xx~`x~`~xxx~f~x`~x~xf`x~~xx~`x~~x~x~f`x~~~~~`~~~x~x~f`~~~~`~~`~x~f~~`xxf`x~~~xx~`~~xx~`~~xxx~~x~~`x~xx~`~~xxx~xf`x~~x~~`x~~x~`~x~~~~``~xf`x~~x~`~~~~fx~xfx~`x~~f`x~~xx~`~~x~`xxf`x~~x`~~~`~~~xx~~fx~xx~x~~xfx~`~~xxxx~~xxx~`~~~~~xx~~x~~~`~~~~x~fxxxx~~x~~`~~x`~`~xx~~xx~~`~~~xfxx~xxfx~xxxf`x~~x~`~~xx~~xx~xxxf`x~~~~`~~~~xx~~fx~xx~xxxf`x~~~~`~~xxx~~xxx~~fxx~``~xx~~x~`~~~~fxx~~`~~`x~xf`x~~fx~`~f`x~~xxx~`x~~x~fxxx~xf`x~~~~`x~~~x~xf`x~~~~`x~~~~xxx~~f`x~~x~`~~~x~`xxf`x~~`~~`x~~~f`x~~fx~`x~x~xxx~~xx~`~f`x~~~~~xx

Diverse Baudraten, Parity, Xon/Xoff hab ich geändert, hat aber nichts verändert.
Da es bei drei verschiedenen Programmen die gleiche Ausgabe liegt denke ich es liegt an der Maschine.
Jemand eine Idee was da falsch sein könnte?
Es ist eine CTX 400 Bj.88

Danke im Vorraus
Jan
TOP    
Beitrag 13.01.2018, 18:11 Uhr
platsch
platsch
Level 3 = IndustryArena-Techniker
***
Gruppe: Mitglied.DE
Mitglied seit: 01.11.2017
Beiträge: 255

Wie in den meisten Fällen steht das Problem höchstwahrscheinlich vor der Maschine. wink.gif
Die Schnittstellenparameter der V24/RS232-Schnittstellen bestehen nicht nur aus Baudrate und Parität.
Alle Parameter, mit Ausnahme der Schnittstellen-Nummer, müssen exakt gleich eingestellt sein! An der CNC-Steuerung und am PC, der über das Nullmodem-Kabel mit der CNC-Steuerung verbunden ist.
Dort, wo auch noch das Datenformat einstellbar ist, muß das auch auf ASCII-Code, bzw. Lochstreifenformat eingestellt werden. Der beschriebene "Datensalat" läßt vermuten, das der Sender auf ein "PC-Datenformat" eingestellt ist.
Ein paar Tips und Informationen zum Thema Datenübertragung via RS232/V24 per PN.

Der Beitrag wurde von platsch bearbeitet: 13.01.2018, 18:20 Uhr
TOP    

Antworten ist nur für Mitglieder möglich, bitte anmelden oder registrieren.



1 Besucher lesen dieses Thema (Gäste: 1)
0 Mitglieder: