530.253 aktive Mitglieder*
2.322 Besucher online*
Kostenfrei registrieren
Anmelden Registrieren
FANUC Forum

Matra VTC 30 nach Werkzeugwechsel - Fährt nicht korrekt

Beitrag 02.10.2020, 11:44 Uhr
Sket-PerSteel
Sket-PerSteel
Level 1 = IndustryArena-Lehrling
*
Gruppe: Mitglied
Mitglied seit: 08.04.2020
Beiträge: 2

Hallo zusammen,

ich habe das Problem das meine Werkzeugmaschine immer nach dem Einwechseln des Werkzeuges, nicht wie gewünscht mit der Korrektur an das Werkstück heran fährt, sondern nach oben weg in Störung. (In den Werkzeug Wechselbereich)

Das folgende Beispiel Programm habe ich benutzt...

%
O100
(PROGRAM NAME)
(#7 - END MILL HSS D 4MM COMP COMPUTER - RADIUS COR VALUE 0)

G90 G94 G17 G49 G40 G80
G0 G28 G91 Z0
G90
G55

(AUSSERHALB KONTUR - SCHLICHTEN)
(COMP COMPUTER - RADIUS CORRECTOR VALUE 0)
(END MILL HSS D 4MM)
M19
G30 G91 Z0
M06 T07
G90
G98
S2387 M3
M8
G0 X1.949 Y4.938
G43 H7
Z2. (HIER sollte der Fräser eigentlich runter fahren zum Werkstück, fährt aber hoch)
Z0.5
G1 Z-1. F48
G3 X1.241 Y2.199 I1.015 J-1.723 F119
G2 X1.232 Y-2.213 I-3.348 J-2.199
G3 X1.928 Y-4.955 I1.719 J-1.023
G0 Z2.
G43 Z2.
M5
G28 G91 Z0
G90
M1

M9
G28 G91 Z0
G28 G91 X0 Y0
M30
%

Koordinaten etc. sind korrekt.
Irgendwie glaube ich hängt es mit dem G28 Befehl zusammen?

Vielen Dank
TOP    
Beitrag 02.10.2020, 15:10 Uhr
Palermo
Palermo
Level 2 = IndustryArena-Facharbeiter
**
Gruppe: Mitglied
Mitglied seit: 18.12.2006
Beiträge: 133

Pack mal das "H7" vor dem G43

Kann sein das die Maschine erst die Wekrzeuglänge Positiv verrechnen möchte, dabei aber keinen Wert hat und dann nach dem G43 erst die Länge liest.
TOP    



1 Besucher lesen dieses Thema (Gäste: 1)
0 Mitglieder: