587.998 aktive Mitglieder*
2.478 Besucher online*
Kostenfrei registrieren
Anmelden Registrieren
FANUC Forum

Problem mit Makros

Beitrag 14.09.2023, 08:10 Uhr
Watchx
Level 1 = Community-Lehrling
*

Guten Tag,

seit ein paar Tagen habe ich an meiner Nakamura WT 100 und einem Renishaw RLP40 Messtaster eine Fehlermeldung nach dem Vorpositionieren des Messtasters. Der letzte Satz des Messprogrammes ist N3001 #3000=1 (Bitte Batterie wechseln), dieser Fehler wird mir auch angezeigt.
Jedoch bleibt der Fehler selbst nach mehrmaligem Wechseln der Batterien, Neustart der Maschine.
Der Messtaster an sich sowohl auch die Empfangsstation sagen "Batterie Ok"

Im Nullpunktprogramm gibt es unter dem Punkt "Ausspannlänge" die Zeile
IF [#1 EQ #0] THEN #3000=1

Jedoch finde ich keine Informationen zu den Makros #0 und #1 um zu überprüfen ob/warum diese Werte gleich sind und warum #3000 geschaltet wird.

Bin ich da überhaupt auf der Richtigen Spur oder hat da vielleicht jemand eine Ahnung?

Mit freundlichen Grüßen
Daniel

Der Beitrag wurde von Watchx bearbeitet: 14.09.2023, 08:17 Uhr
TOP    
Beitrag 14.09.2023, 11:18 Uhr
Watchx
Level 1 = Community-Lehrling
*

Update: scheint wohl nichts mit der ausspannlänge und dem #1 und #0 zu tun zu haben, da zwar auch #3000 aktiv wird allerdings sollte dann eine andere Fehlermeldung kommen. Falls das bei Überlegungen hilft
TOP    
Beitrag 14.09.2023, 14:05 Uhr
Paddyo0
Level 3 = Community-Techniker
***

QUOTE (Watchx @ 14.09.2023, 12:18 Uhr) *
Update: scheint wohl nichts mit der ausspannlänge und dem #1 und #0 zu tun zu haben, da zwar auch #3000 aktiv wird allerdings sollte dann eine andere Fehlermeldung kommen. Falls das bei Überlegungen hilft

Moin Watchx,

#0 wird benutzt um abzufragen ob #1 definiert ist oder nicht. IF [#1 EQ #0] THEN #3000=1 = Wenn #1 gleich #0 dann #3000=1.
Heißt so viel wie: Wenn #1 nicht definiert ist gibt es einen Alarm welcher den Programmablauf stoppt. Das ganze lässt sich dann nur durch Reset wieder löschen.
Falls ich mich irgendwie vertan habe, darf man mich gerne korrigieren.

Um zu deinem Problem zurück zu kommen, glaube ich auch dass das ganze nichts mit der Ausspannlänge zu tun hat. Leider kenne ich mich mit Messtastern nicht aus. Kannst du möglicherweise noch mehr vom Programminhalt des Messtasters hier posten?
Vielleicht hilft das weiter.

Der Beitrag wurde von Paddyo0 bearbeitet: 14.09.2023, 14:07 Uhr


--------------------
Gruß,

Patrick
TOP    



1 Besucher lesen dieses Thema (Gäste: 1)
0 Mitglieder: